Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 24, 2026 - 17:45 EDT
Scheduled
ITS will be running system maintenance on the Kace Work Order system. As a result, Kace will be unavailable starting at 6:00 PM and will remain unavailable throughout the night.
Posted Jul 24, 2026 - 17:41 EDT
This scheduled maintenance affected: Business Operations (Work Order Ticketing).