Duo Universal Push

Incident Report for Harford Community College

Resolved

Both DUO and Microsoft show their issues as resolved. We will consider this problem solved.
Posted Feb 23, 2026 - 13:35 EST

Investigating

We are experiencing issues with logging into any service that uses DUO for authorization. This appears it could be a Microsoft issue and not anything we can easily fix, but NSA is looking into it.
Posted Feb 23, 2026 - 10:04 EST
This incident affected: Accounts & Identity Management (Multifactor Authentication (Duo) - Employees Only, Authentication Services).