Office 365 Web Apps

Incident Report for Harford Community College

Resolved

The login issue with Microsoft 365 web apps has been resolved. If you experience any issues, try clearing your browser history but if problems remain, please contact the Help Desk at 443-412-2477, option 3.
Posted Sep 14, 2026 - 11:06 EDT

Investigating

We are currently investigating a issues occurring when trying to log into Office 365 web applications such as Word, PowerPoint, Excel. At this time, there are no issues logging into Microsoft 365 or with applications such as Outlook, OneDrive, and SharePoint. Updates will be posted as they become available.
Posted Sep 14, 2026 - 07:11 EDT
This incident affected: Communications (Microsoft 365).