Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 24, 2024 - 10:00 EST
Scheduled
ITS will be upgrade the Argos reporting software server on Tuesday, December 24th from 10:00 AM - 2:00 PM. Argos reporting will be unavailable during this time frame.
Posted Dec 20, 2024 - 15:30 EST
This scheduled maintenance affected: Business Operations (Argos Reporting Platform).